Requiring CMake 2.4.5 ?
Paulo Jorge Guedes
Paulo.Guedes at artelecom.pt
Mon Jan 29 16:55:44 GMT 2007
> -----Original Message-----
> From: Alexander Neundorf [mailto:neundorf at kde.org]
> Sent: segunda-feira, 29 de Janeiro de 2007 16:49
> To: kde-core-devel at kde.org
> Subject: Re: Requiring CMake 2.4.5 ?
> On Monday 29 January 2007 08:47, Tomas Mecir wrote:
> > 2007/1/28, Alexander Neundorf <neundorf at kde.org>:
> > > For this we would need to raise the required version of CMake to
> > > 2.4.5.
> > It might be worth mentioning that the required version -already-
> > to be >2.4.3, as it's not possible to build kdelibs4 with CMake
> > - it fails with a lot of errors like:
> > CMake Error: Attempt to add link library "-lpthread" to target
> > "kconfigtestgui" which is not built by this project.
> There was a commit which broke the compilation with 2.4.3, I made it
> again yesterday.
> So, right now CMake 2.4.3 still works for KDE4.
I just updated from 2.4.5 to 2.4.6 and it fixed a problem on win32.
More information about the kde-core-devel