Some porting from KIO::Jobs to KJobs

David Faure faure at
Mon Jan 15 15:09:02 GMT 2007

On Saturday 13 January 2007 23:18, Rafael Fernández López wrote:
> -        void totalFiles( KIO::Job *job, unsigned long files );
> +        void totalFiles( KJob *job, unsigned long files );

I don't understand the point of this change. This signal is emitted by CopyJob, it might
as well have "KIO::CopyJob* job" as the argument type, since it's always "this".
KJob doesn't know about files or directories, in any case.
What difference does it make to observer or uiserver, whether they get totalFiles(KJob*,ulong)
or totalFiles(KIO::Job*,ulong)? It will only ever be emitted by a KIO::CopyJob anyway.

Same for the other signals.

I just don't get it. Why not fix the slot in Observer to say KIO::Job instead?

> If anybody complains, I will be committing this on tuesday.

Funny one -- I guess you meant "if nobody complains" ;) 
(if anybody == if someone)

David Faure, faure at, sponsored by Trolltech to work on KDE,
Konqueror (, and KOffice (

More information about the kde-core-devel mailing list