Naming of blitz ?

Mosfet daniel.duley at
Fri Aug 24 22:48:53 BST 2007

Okay, if there are no objections on Monday I'm going to switch to qimageblitz, 
because that is my favorite :)

I'm waiting until Monday because a) It's binary incompatible and b) I'm going 
through Qt and pixman right now and just got my head wrapped around byte 
multiplication and using INTERPOLATE_255 for alphablending. If I stop now 
I'll probably forget: short attention span :P

On Friday 24 August 2007 3:46:54 pm Sune Vuorela wrote:
> On 2007-08-24, Matthew Woehlke <mw_triad at> wrote:
> > Mosfet wrote:
> >> Yes, I think we can change the header and library to "qimageblitz" if
> >> that will solve the problem for you.
> >
> > Anything wrong with just 'qblitz' (or 'blitzfx')? :-)
> >
> > Also, it is only the .so name that needs to change? (Maybe the headers
> > also, but i.e. not what we call it to users?)
> From my point of view, it doesn't matter what it is called from a user
> perspective, I mostly care about the name from a technical perspective -
> to avoid clashes with something existing.
> qblitz, blitzfx, qimageblitz and many other things fits this nicely, it
> looks like.
> /Sune

More information about the kde-core-devel mailing list