Adding ThreadWeaver libraries to kdelibs
wheeler at kde.org
Fri Sep 8 03:29:21 BST 2006
On Thursday 07 September 2006 20:59, Simon Hausmann wrote:
> The fact that it is a regular word as well as an abbreviation makes it IMHO
> a worse choice than something a little bit more descriptive and certainly
> not ambigious. Having 'limit' or 'maximum' (I prefer the latter) in the
> name is more consistent and therefore also easier for non-native speakers
> IMHO, because they can more easily recognize it and relate it to API
> they've seen before.
limit() was also what popped into my head, but I think maximum() works even
better for an API method.
Even as a native speaker when I first read the mail (though, admittedly not
the header) I thought "capabilities" since I'm familiar with other APIs that
use "cap" or "caps" for that.
I also think in this case adding "jobs" would be more expressive:
maximumJobs() and setMaximumJobs(). (The other methods are clear enough since
they take the job as a parameter.)
Had this been an actual emergency, we would have fled in terror, and you would
not have been informed.
More information about the kde-core-devel