Adding ThreadWeaver libraries to kdelibs
hausmann at kde.org
Thu Sep 7 19:59:03 BST 2006
On Thursday 7. September 2006 20:10, Thomas Zander wrote:
> On Thursday 7 September 2006 19:56, Alexander Neundorf wrote:
> > > OK, getter added. About the name - I think cap is very descriptive.
> > Ok, I'm no native speaker. To me it's not "very descriptive".
> > What does cap() stand for ? Capacity ? Capability ? Something else ?
> Lol; its not an abbreviation. Its a normal English word.
> Webster describes it as:
> an upper limit (as on expenditures) : CEILING
> Which fits perfectly with the concept used.
No doubt it fits, but you see that it can be confusing for non-native speakers
not being familiar with the word.
"I don't know that word. Is it an abbreviation for capacity or capability?
Perhaps, it doesn't seem to be a common term in the API I've used so far."
The fact that it is a regular word as well as an abbreviation makes it IMHO a
worse choice than something a little bit more descriptive and certainly not
ambigious. Having 'limit' or 'maximum' (I prefer the latter) in the name is
more consistent and therefore also easier for non-native speakers IMHO,
because they can more easily recognize it and relate it to API they've seen
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
More information about the kde-core-devel