proposal for kaction api change
rodda at kde.org
Fri May 5 15:33:05 BST 2006
Some of my responses I wrote in response to Jason, however...
On Friday 05 May 2006 12:45, Jens Herden wrote:
> and use only one setter and getter for our shortcuts, like:
> setKShortcut(setShortcut(const KShortcut& shortcut, ShortcutTypes type =
> static_cast<ShortcutType>(Shortcut | DefaultShortcut));
> const KShortcut& kShortcut(ShortcutTypes types = Shortcut) const;
> Please note that the names are intentional not setShortcut() and shortcut()
> because I do not want to hide the QAction methods.
I think we should hide the QAction methods. This is KDE, we encourage
application developers to abide by our UI conventions, and changes made to
the QAction's shortcuts would be quite hard to sync with the k-methods. So
far that I have seen it is not often that we deal with QAction pointers to
KActions, especially since all the ported code only ever worked with KAction.
I like the idea behind your other ideas, so I'll just wait for a bit of
response to my other email then make some changes.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
More information about the kde-core-devel