RFC: kdDebug() -> kDebug()

Maks Orlovich mo85 at cornell.edu
Sat Jan 28 14:51:59 GMT 2006

On Saturday 28 January 2006 09:36, Stephan Kulow wrote:
> Hi!
> I would like to remove some stupidness from our API: the d between k
> and Debug() and wonder what others feel about it taking that it will
> require some changes in the code :)
> The reason it's there is that kDebug() was already taken by a function
> basically replacing qDebug() - but as this function is gone, I'd like to
> change that for KDE4. What do you think?

If you do do that, may I suggest a KDE3_SUPPORT (or how do you call it these 
days?) alias, unless we think that Laurent's scripts may be usable as a 
kde3to4? tool ;-)

More information about the kde-core-devel mailing list