which compilers do we want to support with KDE 4 ?

Gregory Hayes syncomm at gmail.com
Sun Jan 22 04:08:43 GMT 2006

Personally, I would target the LSB 3.x. The minimum gcc supported is 3.4.4.
The release notes ( http://www.linuxbase.org/LSBWiki/ReleaseNotes3 )
specifically state:

"However, in accordance with the roadmap published in August 2004 when LSB
2.0 was released, LSB 3.0 requires a newer release of the underlying ABI
used for C++ support. For most vendors, this means that *gcc 3.4* or later
(actually, the minimum acceptable level is 3.4.4), or compatible
equivalent must
be used, and any C++ application built with *gcc 3.3* or earlier must be

I really can't see any vendors _not_ supporting at least gcc 3.4 (probably
4.x) by the time KDE 4 is released. If we want to, we can get things working
with a broken and depreciated c++ compiler, but it doesn't seem worth the
effort. Especially when it is in contradiction to the definition of the
"standard" Linux system we can expect from end users at release.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20060121/a73e73e7/attachment.htm>

More information about the kde-core-devel mailing list