Patch for kabc resources
Tobias Koenig
tokoe at kde.org
Tue Jan 6 16:04:45 GMT 2004
On Tue, Jan 06, 2004 at 02:57:39PM +0100, Bo Thorsen wrote:
Hi Bo,
> - removes the writeConfig method that just called the superclass method (might
> not be a good idea, since this would make it impossible to introduce writing
> config items later - I need info on wether the existance of this method is by
> choice)
I'd like to keep this method to have an additional abstraction layer to
add new config items. Cornelius?
> - has default implementations of asyncLoad and asyncSave, since the resource
> subclasses I've seen all have this exact implementation. Code duplication is
> bad, so it might as well be in the superclass
Holger suggested to do it the other way around. We should force to
implement an asyncLoad/Save and give an default Implementation for
syncLoad/Save which calls the async methods.
The rest of the patch looks ok for me.
> Resource::Resource( const KConfig *config )
> - : KRES::Resource( config ), mAddressBook( 0 )
> + : KRES::Resource( config )
> {
> + d = new ResourcePrivate( 0 );
> }
Or maybe
+ : KRES::Resource( config ), d( new ResourcePrivate( 0 ) )
?
Ciao,
Tobias
--
Can a government that shoots at reporters be democratic?
Separate politics from religion and economy!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20040106/d142a0ad/attachment.sig>
More information about the kde-core-devel
mailing list