Patch for kabc resources
Bo Thorsen
bo at sonofthor.dk
Tue Jan 6 13:57:39 GMT 2004
This patch fixes a bunch of annoying parts of the kdelibs kabc Resource class.
It:
- finishes the implementation of the private pointer and moves the
mAddressBook attribute to it. mAddrMap is not moved, since it's used directly
by most subclasses
- removes the writeConfig method that just called the superclass method (might
not be a good idea, since this would make it impossible to introduce writing
config items later - I need info on wether the existance of this method is by
choice)
- has default implementations of asyncLoad and asyncSave, since the resource
subclasses I've seen all have this exact implementation. Code duplication is
bad, so it might as well be in the superclass
- Removes the bogus doOpen and doLoad abstract methods. It does not make sense
that these have default implementations in the kresources Resource class, and
then this subclass forces kabc resources to reimplement the same default
implementations
I have tested that it compiles, but I want feedback on wether this should be
committed or not. It's BIC, but since the resources were not part of 3.1,
that shouldn't be a problem.
Comments?
Bo.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pa
Type: text/x-diff
Size: 4562 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20040106/aae342f3/attachment.diff>
More information about the kde-core-devel
mailing list