Compile errors accross the CVS with SuSE 8.2

Andras Mantia amantia at
Tue Jul 15 07:14:56 BST 2003


 With a fresh, clean install of SuSE I run into compile errors at various 
places. Eg. kdenetwork fails to compile:

if g++ -DHAVE_CONFIG_H -I. -I/development/sources/kde-head/kdenetwork/krfb/
krfb -I../.. -I/development/sources/kde-head/kdenetwork/krfb/libvncserver -I/
development/sources/kde-head/kdenetwork/krfb/srvloc -I/opt/kde-cvs/include -
I/usr/lib/qt3/include -I/usr/X11R6/include   -DQT_THREAD_SUPPORT  -
D_REENTRANT -D_FILE_OFFSET_BITS=64  -Wnon-virtual-dtor -Wno-long-long -Wundef 
-Wall -pedantic -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 
-D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -O2 -Wformat-
security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-
DQT_NO_TRANSLATION  -MT rfbcontroller.o -MD -MP -MF ".deps/rfbcontroller.Tpo" 
  -c -o rfbcontroller.o `test -f '/development/sources/kde-head/kdenetwork/
krfb/krfb/' || echo '/development/sources/kde-head/
kdenetwork/krfb/krfb/'`/development/sources/kde-head/kdenetwork/krfb/krfb/; \
then mv ".deps/rfbcontroller.Tpo" ".deps/rfbcontroller.Po"; \
else rm -f ".deps/rfbcontroller.Tpo"; exit 1; \
In file included from /development/sources/kde-head/kdenetwork/krfb/krfb/
newconnectiondialog.h: No such file or directory

KOrganizer also fails to compile:
if /bin/sh ../libtool --silent --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -
I. -I/development/sources/kde-head/kdepim/korganizer -I.. -I/development/
sources/kde-head/kdepim/korganizer/interfaces -I/development/sources/kde-
head/kdepim/libkdepim -I/development/sources/kde-head/kdepim -I/opt/kde-cvs/
include -I/usr/lib/qt3/include -I/usr/X11R6/include   -DQT_THREAD_SUPPORT  -
D_REENTRANT  -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -
Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -
Wcast-align -Wconversion -Wchar-subscripts -O2 -Wformat-security -Wmissing-
format-attribute -fno-exceptions -fno-check-new -fno-common -
DQT_NO_TRANSLATION  -MT publishdialog.lo -MD -MP -MF ".deps/publishdialog.
Tpo" \
  -c -o publishdialog.lo `test -f '/development/sources/kde-head/kdepim/
korganizer/publishdialog.cpp' || echo '/development/sources/kde-head/kdepim/
cpp; \
then mv ".deps/publishdialog.Tpo" ".deps/publishdialog.Plo"; \
else rm -f ".deps/publishdialog.Tpo"; exit 1; \
In file included from /development/sources/kde-head/kdepim/korganizer/
publishdialog_base.h: No such file or directory

The original error message for KOrganizer was similar, but for another file 
(calendarview.cpp), I've just played with the file order in the
The problem is that the UIC is not run for the .ui files and thus the .h files 
are not generated.

For kdepim I saw an error message at the make -f Makefile.cvs step:
*** Postprocessing Makefile templates
unknown icon type kpilot in kpilot/kpilot/Icons/ (kpilot-hotsync.

In case of kdenetwork everything went OK.
Now is this an am_edit, autoconf (2.57) or automake (1.7.2) bug or something 
else? What can I do (aside that I will 
downgrade my autoconf now to the version I've used with SuSE 8.0.)? I've tried 
and no luck with autoconf 2.53 and automake 1.6.3...


Quanta Plus developer -
K Desktop Environment -

More information about the kde-core-devel mailing list