Compile errors accross the CVS with SuSE 8.2

Adriaan de Groot adridg at
Tue Jul 15 08:10:53 BST 2003

Hash: SHA1

On Tuesday 15 July 2003 08:14, Andras Mantia wrote:
> Hi,
>  With a fresh, clean install of SuSE I run into compile errors at various
> places. Eg. kdenetwork fails to compile:

> In file included from /development/sources/kde-head/kdenetwork/krfb/krfb/
> /development/sources/kde-head/kdenetwork/krfb/krfb/rfbcontroller.h:27:33:
> newconnectiondialog.h: No such file or directory
> KOrganizer also fails to compile:
> /development/sources/kde-head/kdepim/korganizer/publishdialog.h:29:32:
> publishdialog_base.h: No such file or directory

This problem has been reported several times already (mostly on the -pim 
mailing list). The problem is that there are sources that need to be compiled 
from .ui files - like publishdialog_base.h, which comes from 
publishdialog_base.ui - but the .uis are _not_ compiled before the .h files 
are included elsewhere.

One thing to try - no guarantee of success though - is to move the .ui files 
forward in the _SOURCES list.

Another "fix" is

	make -k ; make

> For kdepim I saw an error message at the make -f Makefile.cvs step:
> *** Postprocessing Makefile templates
> unknown icon type kpilot in kpilot/kpilot/Icons/
> (kpilot-hotsync. png)

Not a problem.

> In case of kdenetwork everything went OK.
> Now is this an am_edit, autoconf (2.57) or automake (1.7.2) bug or
> something else? What can I do (aside that I will
> downgrade my autoconf now to the version I've used with SuSE 8.0.)? I've
> tried and no luck with autoconf 2.53 and automake 1.6.3...

It's a problem on FreeBSD with ac 2.57 and am 1.7.4, and has been reported on 
other Linux versions as well. 

- -- 
pub  1024D/FEA2A3FE 2002-06-18 Adriaan de Groot <groot at>
     Key fingerprint = 934E 31AA 80A7 723F 54F9  50ED 76AC EE01 FEA2 A3FE
Version: GnuPG v1.0.7 (FreeBSD)


More information about the kde-core-devel mailing list