meinproc fails to find KDE catalogs

Jeff Stuart jstuart at
Fri Oct 25 07:52:32 BST 2002

When I attempt to compile kdelibs when it hits the documentation, I get
the following errors for ALL docbook files! 

make[1]: Entering directory `/usr/local/src/kde-cvs/kdelibs/doc/kspell' 
KDELIBS_UNINSTALLED=yes ../../kdoctools/meinproc --check --cache
index.cache.bz2 ./index.docbook 
index.docbook:6: error: failed to load external entity "dtd/kdex.dtd" 
index.docbook:8: error: Entity 'language' not defined 
<book lang="&language;"> 
index.docbook:8: validity error: No declaration for attribute lang of
element book 
<book lang="&language;"> 
index.docbook:11: error: Entity 'kspell' not defined 
<title>The &kspell; Handbook</title> 
index.docbook:11: validity error: No declaration for element title 

(error log chopped off for brevity)

This is the LATEST CVS as of 2:30 AM EST 10/24/2002. 

libxml, libxslt versions: 

$ rpm -qa | grep libxml2 

$ rpm -qa | grep libxslt 

This is the EXACT same error as was reported by bug # 41374. I TRIED the
workaround. It failed.
Jeff Stuart <jstuart at>

>> Visit to unsubscribe <<

More information about the kde-core-devel mailing list