Short hostnames in URLs

Dawit A. adawit at
Sat Aug 10 07:54:49 BST 2002

On Friday 09 August 2002 09:59, Lubos Lunak wrote:
> Dne pá 9. srpen 2002 07:52 Dawit A. napsal(a):
> > On Thursday 08 August 2002 04:38, Lubos Lunak wrote:
> > > Dne čt 8. srpen 2002 03:43 Dawit A. napsal(a):
> > > > On Wednesday 07 August 2002 12:45, Lubos Lunak wrote:

>  I was just trying to say that I don't undestand why it should be moved
> into its own plugin when there would be no difference besides it being in
> its own plugin.

Ahh, but there is.  It is now simple to add an option to disable individual 
plugins.  Each can also provide its own control module like the ebrowsing 
(ikws) plugin does.  This is why I wanted this feature to be separated out.  
I am almost certain that people with a much slower DNS (some dial up service) 
or a capped bandwidth limit will complain about such plugin since it has a 
tendency to generate a lot of traffic (I mean while attempting the look up). 

Note I know this can also be done in the shorturi filter plugin using a simple 
flag, but I think we should resist this tendency. 

>  Unless you know a better place where to put the lookup, I've attached
> (hopefully final and everybody sufficiently pleasing) another version. The
> lookup is done in an extra URIFilter, and minicli uses this filter only for
> the final filtering of the entered command (who cares the icon for local
> hostnames will be wrong). This makes thing feature work fine in Konqy or
> wherever else where it doesn't cause any serious problem, and not using it
> in minicli while typing avoids any possible delays. I've also increased the
> timeout to 1s.

Great.  I withdraw my objection then.  This is a much better approach than 
sticking the code into the shorturi filter. Perhaps an option to enable or 
disable the plugin can be added into the ebrowing module as well ?

[ ] Enable hostname lookup

I can add this once you add the plugin if you do not object or you can add it 
yourself if you want.  One last thing if I may.  Perhaps a bit more 
descriptive name is in order.  For example "domainLookupFilter" which is what 
the plugin effectively does. Anyways, that does not really matter, just being 
picky :)

Dawit A.

More information about the kde-core-devel mailing list