Review Request: Bounding boxes for GameObjects

Laszlo Papp lpapp at kde.org
Wed Dec 12 19:11:37 UTC 2012



> On Dec. 9, 2012, 7:52 p.m., Laszlo Papp wrote:
> > I was wondering if it made more sense to use the term "axis-aligned bounding box" (AABB) for the filename and class rather than just "axis-aligned box". The former seems to be more common usage out there.
> 
> Arjen Hiemstra wrote:
>     Not really. The class itself is not limited to bounding boxes thus it makes no sense to use that name. Furthermore, the getter is called boundingBox() so explicitly states that it is a bounding box.
>     
>     It is similar to QRect in that regard. There are methods in QGV that return QRects for their bounding rects, but the QRect class is more general-purpose.

1) Will it be used for anything else than bounding box?

2) Now you say actually, the getter is also a bit unclear as the return value is an axis-aligned box, but the getter name is generic (i.e. not axisAlignedBoundingBox()), so it could be different according to the name, not just axis-aligned. So one is specifying the type of bounding box, but the other does not. Perhaps, it would be more consistent by using as close terms as possible.


- Laszlo


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/106712/#review23220
-----------------------------------------------------------


On Dec. 1, 2012, 3:16 p.m., Felix Rohrbach wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/106712/
> -----------------------------------------------------------
> 
> (Updated Dec. 1, 2012, 3:16 p.m.)
> 
> 
> Review request for Gluon.
> 
> 
> Description
> -------
> 
> This adds bounding boxes for GameObjects, based on the patch for Components. I'm not really sure if the rotation works, as I don't have much experience in graphics.
> 
> 
> Diffs
> -----
> 
>   core/axisalignedbox.h 5d9cab1 
>   core/axisalignedbox.cpp 9e7e3eb 
>   engine/gameobject.h c042e94 
>   engine/gameobject.cpp a0d059f 
> 
> Diff: http://git.reviewboard.kde.org/r/106712/diff/
> 
> 
> Testing
> -------
> 
> Compiles (x86_64, Qt 4.8.3)
> 
> 
> Thanks,
> 
> Felix Rohrbach
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/gluon/attachments/20121212/22746bed/attachment.html>


More information about the Gluon mailing list