[digiKam-users] 5.6.0 crash-pictures gone-drive space still allocated

Sveinn í Felli sv1 at fellsnet.is
Thu Mar 8 06:35:49 GMT 2018

If everything else fails, I'd try PhotoRec from the TestDisk suite:

It can 'extract' any kind of file from 'deleted' parts of a HDD, SSD or 
Flash-card. It may have to be run from a Live-distribution if the 
deleted files are on the same partition as your OS.
It's quite radical, sometimes it may be able to recover the folder 
structure, but sometimes the files will be dumped all in one folder.

It has saved my ass more than once, when deleting files from a card I 
thought I already saved into my collections (but had not)...

BTW, anyone intending to give or sell a Flash-card, HDD or SSD should 
pass those through PhotoRec, you will be surprised how much is left of 
older files, even if you have deleted all and reformatted once.

Sveinn í Felli

Þann mið  7.mar 2018 19:25, skrifaði rutile:
> I am travelling, and have a 'new' laptop with Digikam 5.6.0 on Ubuntu 17.10
> Short Version:
> After a Digikam glitch, Digikam has restarted as a new installation, and all
> my pictures located in the /Pictures folder on the internal SSD card are
> missing, but hard drive space is still allocated to them.
> Long Version:
> I have my images and Digikam database in /home/me/Pictures.
> I copied the subfolders in my Pictures folders to an external hard drive
> (~100 GB), using the file manager.  The external hard drive was a database
> connection in Digikam as a removable hard drive, originally with a separate
> set of images.
> After a short trip, I restarted my computer, and my original file structure
> was fine, and Digikam operated as usual.  I copied the contents of an SD
> card to a new folder created in Digikam, and worked with the pictures after
> copying.  I then copied the contents of a second SD card to a new folder on
> the external hard drive using the file manager.  (the last two sentences are
> correct to the best of my recollection), while Digikam was still open.
> While the files were copying to the external hard drive, I tried to use
> Digikam to open an image in the Digikam database in a folder in /Pictures.
> Digikam gave an error "cannot open image".  I shut digikam, and reopened it,
> and Digikam started from scratch with the option to set the database
> locations.
> According to the fresh restart of Digikam, and the file manager, my
> /home/me/Pictures folder is empty except for newly created Digikam database
> files, and a 24.6 kb cache folder (plus empty Presets folder).  However, the
> available hard drive space shows only 28GB available out of a 256 GB SSD
> drive, reflecting the presence of the missing ~100 GB of pictures.
> A folder on the Desktop containing pictures that was also in the Digikam
> database is apparently unaffected by this glitch.
> 1)  Is there anyway to recover the images from my laptop SSD drive?  Is
> there drive space allocated to the new "digikam trash" somewhere that they
> might be hiding?  I had not backed up the Digikam database.  The copies on
> the external hard drive seem to be OK, but now I'm back to just one copy of
> the these once in a lifetime images, and that is making me nervous- i'd like
> to recover any images from the SSD card, and am trying to limit any writing
> to the disk until I resolve this, meaning new images are being only copied
> to the external hard drive.
> 2) if the images are not recoverable, how do I free up the hard drive space
> that is being allocated to them?
> Thanks
> --
> Sent from: http://digikam.1695700.n4.nabble.com/digikam-users-f1735189.html

More information about the Digikam-users mailing list