[Digikam-users] testing XMP fixes, git not compiling / configuring

jon piesing jon33040 at yahoo.co.uk
Sun Mar 25 13:04:21 UTC 2012


Hi,

Thanks for the reply. 


The attached file contains the results of running cmake -DCMAKE_BUILD_TYPE=debugfull -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` .. >& foo.

This set of parameters are taken from the instructions http://www.digikam.org/drupal/download?q=download/GIT. 

As far as I can see from the messages, it looks like it's taking kipi-plugins (etc) from the git versions.


This is a clean check-out from git yesterday. I deleted the entire directory hierarchy from earlier in the week in case that was interfering.

Jon




>________________________________
> From: Gilles Caulier <caulier.gilles at gmail.com>
>To: jon piesing <jon33040 at yahoo.co.uk>; digiKam - Home Manage your photographs as a professional with the power of open source <digikam-users at kde.org> 
>Sent: Sunday, 25 March 2012, 14:40
>Subject: Re: [Digikam-users] testing XMP fixes, git not compiling / configuring
> 
>Can you give us a trace of error. All compile and work fine here.
>
>If you have an error in panorama, it's probably a Boost lib problem...
>
>Using current code from git/master is the right way to test. You must
>take a care to use all kdegraphics/libs from git/master as digiKam and
>kipi-plugins. With cmake the is an option to turn on. Look README file
>for details.
>
>Best
>
>Gilles Caulier
>
>2012/3/25 jon piesing <jon33040 at yahoo.co.uk>:
>> I've been irritated by the XMP issues for some time so I was very pleased to
>> see some of them getting closed for 2.6.0.
>> I thought I'd try to checkout the code from git with these fixes and see how
>> they behaved.
>> Unfortunately both times I've tried over the last few days, what's in git
>> doesn't compile.
>>
>> Is what's in git expected to configure and compile? Are there any times /
>> days when it's more likely to compile than others?
>> Should I just wait for beta3 to test the XMP fixes?
>>
>> The first time I tried, something in libpanorama wouldn't compile. I know C
>> and Java but the error message was complete gibberish to me.
>> The second time (today), the contents of git won't even configure.
>>
>> If what's in git is supposed to configure & compile then I have a log file I
>> can send out showing a variety of messages (e.g. complaints about lack of a
>> version.h file for libkdcraw).
>>
>> Jon
>>
>> _______________________________________________
>> Digikam-users mailing list
>> Digikam-users at kde.org
>> https://mail.kde.org/mailman/listinfo/digikam-users
>>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20120325/f1c6ee14/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: foo
Type: application/octet-stream
Size: 12913 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20120325/f1c6ee14/attachment-0001.obj>


More information about the Digikam-users mailing list