[Digikam-users] digikam2 dependency openni-utils / philip5 PPA

Vlado Plaga rechner at vlado-do.de
Fri Aug 12 10:45:32 BST 2011

On Fri, 12 Aug 2011 11:49:41 +0800
manfred <manfred.1980 at freenet.de> wrote:

> @ Vlado
> I tried dpkg ignoring dependencies. Like before, openni-utils and
> libopenni is installing, but not configuring. This way digikam2
> doesn't install.

It is definitely possible (and should not be too difficult) to install
packages in Debian (=Ubuntu) with broken dependencies. Whether this
should be recommended is a different story... but if that's the easiest
way to get digiKam to work, I'd do it.

Probably you need to "apt-get remove openni-utils libopenni". Here is
the install command I used to install digikam, from my Bash
"history" (all in one line):

# dpkg -i --ignore-depends=libopenni

These are not really kde47 DEBs, since I compiled them myself for KDE
4.6 on PPC (but without changing the Debian description files).

Instead of listing individual files a "*.deb" should also work.

> @ Philip
> If it's not possible to regular install openni on my computer I can
> not use Digikam2.

Is it not possible? Have you tried Philip's extra PPA?



> I will try to get more informations about openni
> and how to install it on computers not supporting SSE3, I still
> think, thats the problem.

That's of course possible, judging from what you write in your mail
from Thu, 11 Aug 2011 09:37:17:

> openni-utils ( "is going to be
> configured" ... Illegal instruction

On the other hand it seemed unlikely to me, so I tried it myself, on my
2007 AMD64 notebook (with SSE2, but not SSE3, according
to /proc/cpuinfo).

I added Philip's PPA (add-apt-repository), apt-get updated, then called
"install digikam2" - voilĂ . Thanks, Philip, good work!

Manfred: I saw you still use the i386 version. Is your Pentium 4 not
capable of running the AMD64 version, or are other closed-source
programs holding you back? According to Wikipedia[1] post-2004 Pentium
4 should be able to run the AMD64 Kubuntu. By now probably most
developers are running that, if only to access more than 2 or 3 GByte
of RAM, so maybe you want to change as well?


[1] http://en.wikipedia.org/wiki/Pentium_4



More information about the Digikam-users mailing list