[Digikam-users] digikam2 dependency openni-utils doesn't install Philips PPA

manfred manfred.1980 at freenet.de
Thu Aug 11 10:37:17 BST 2011

thank you for yor reply!

apt-cache showpkg libopenni shows the same result. mentioned dependencies are
(following apostrophed "text" is free translated from the german output)

I have tried force install, just tried it again:
first purged unconfigured libopenni and openni-utils

sudo apt-get -f install libopenni
"will install this too":
"following new packages will be installed":
  libopenni openni-utils
0 aktualisiert, 2 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
"needs to download 0 B of 538 kB of archives to download".
"After this operation 1.470 kB additional diskspace will be used".
"do you want to continue?" [J/n]? j
"not now installed package" openni-utils "is selected".
("reading database" ... 266130 "files and folders are installed at the moment".)
"unzip" openni-utils ("from"
.../openni-utils_1.3.2.1~git110718-natty~ppa1_i386.deb) ...
"not now installed package" libopenni "is selected".
"unzip" libopenni ("from" .../libopenni_1.3.2.1~git110718-natty~ppa1_i386.deb) 
Trigger for man-db "are resolved" ...
openni-utils ( "is going to be configured" ...
Illegal instruction
dpkg: "Error installing" openni-utils (--configure):
"subprocess installed post-installation script returned error exit status 132"
dpkg: "dependency problem doesn't let" libopenni "configure":
 libopenni "depends on" openni-utils; "but":
  "package" openni-utils "is not configured".
dpkg: "Error installing" libopenni (--configure):
 "dependency problems" - "stays unconfigured"
          "Errors installing":
E: Sub-process /usr/bin/dpkg returned an error code (1)

Well, I tried it otherwise. Purge all openni...

sudo apt-get -f install openni-utils
openni-utils ( "gets configured" ...
niLicense: error while loading shared libraries: libOpenNI.so: cannot open
shared object file: No such file or directory
dpkg: "Error processing" openni-utils (--configure):
subprocess installed post-installation script returned error exit status 127

"Errors installing":
E: Sub-process /usr/bin/dpkg returned an error code (1)

some week ago and now again I did search for the 
"niLicense: error while loading shared libraries", no results on google.

More information about the Digikam-users mailing list