[Digikam-users] digikam2 dependency openni-utils doesn't install Philips PPA

Mark Fraser mfraz74+kde at gmail.com
Thu Aug 11 08:44:33 BST 2011

On Thursday 11 Aug 2011 05:07:43 manfred wrote:
> Two weeks ago I updated from digikam rc to digikam2
> I am using
> ppa:philip5/extra
> ppa:philip5/kubuntu-updates
> ppa:philip5/kubuntu-backports
> for my Kubuntu 11.4 KDE 4.7. After updating Digikam2 it didn't start
> anymore.
> I tried a reinstall and found out, the problem is openni-utils and
> llibopenni. They doesn't configure.
> Using synaptic I get the following message (from german):
> E: openni-utils: subprozess installed post installation Script gives error
> 132 E: libopenni: dependency problems - not configured
> digikam shows libopenni as dependency (anybody an idea what for libopenni
> is?) libopenni depends on openni-utils
> openni-utils has error 132
> Philip didn't have an answer. He said:
> "Looks like you don't have package libopenni installed that should be
> installed as a dependency but might not do so. Try to install
> libopenni first and then openni-utils."
> But: libopenni is dependent on openni-utils, not otherwise! Even if I think
> thats strange. Using apt, aptitude or synaptic, all the same problem.
> I downloaded the debs different times on different days, I dont think its a
> download corruption problem.
> Since i can not use openni-utils and so not use digikam 2, i went back to
> digikam 1.9, which is working. But I am not happy with that, now having two
> databases....
> I didn't make it to install openni-utils from source. I thought it might be
> a problem with missing SSE3 on, as my pentium mobile 4 doesn't have it.
> Didn't find anything about openni and digikam on the web.
> any ideas?

apt-cache showpkg libopenni:
Package: libopenni
i386_Packages) (/var/lib/dpkg/status)
 Description Language: 
                  MD5: bd9b74a9a5080e5f4ad93e4913099dfd

Reverse Depends: 
Dependencies: - libc6 (2 2.11) libgcc1 (2 1:4.1.1) libgl1-mesa-
glx (16 (null)) libgl1 (0 (null)) libstdc++6 (2 4.1.1) libusb-1.0-0 (2 
2:1.0.8) openni-utils (0 (null)) 
Provides: - 
Reverse Provides:

Libopenni is supposed to be framework for sensor-based 'Natural Interaction'.

Have you tried running apt-get -f install?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20110811/0978cc75/attachment.html>

More information about the Digikam-users mailing list