[Digikam-users] Digikam 0.9.3 problems continue - getting desperate now

Mark Ovens parish at magichamster.com
Mon May 19 22:42:03 BST 2008

Gilles Caulier wrote:
> Yes, Robert give the right way.
> digiKam use Gphoto2 driver to talk with Canon camera (PTP protocol),
> and only like this, because Canon do not support Usb Mass Storage!
> Second, Canon camera drivers is a mess in gphoto2. it's not the fault
> to gphoto2 developpers, but the complexity to test with Canon stuff...
> If you google "canon + gphoto2 + digiKam", you will see than you is
> not alone (:=))
> note : If you want to help gphoto2 team contact developper into
> #gphoto irc channel

Hi Gilles,

If you can recall from my previous posts about FreeBSD I tried 
re-installing an older version of gphoto2 and the problem was still 
there. But going back to 0.9.2 (even with the latest version of gphoto2) 
it worked OK.

Also, gphoto2 works OK from the command line so the problem seems to be 
something to do with the interface between digikam and gphoto2.

The reason I prefer to d/l from the camera rather than a card reader is 
that the camera marks the photos as downloaded so next time I connect 
the camera I can just do Select->New items in the digikam camera 
dialogue and it automatically selects only those photos taken since the 
last d/l.

I'll get a card reader though as it will make life easier.

Will the svn build instructions work OK on (K)Ubuntu? I'd like to give 
0.9.4 a try.

What Linux distro do you use to develop digikam?



P.S. I am not criticizing you and the other developers about this 
problem, digikam is a great product and I really do want to keep using 
it, I'm getting a bit frustrated about it :(

More information about the Digikam-users mailing list