[Digikam-users] Exiv2 library missing???

Fabien fabien.ubuntu at gmail.com
Tue Dec 5 11:23:25 GMT 2006

Ok, I changed the website and the compile_digikam.txt script.

Daniel Bauer wrote:
> On Tuesday 05 December 2006 09:52, Fabien wrote:
>>I sent an email about that on kde imaging list.
>>With their new check for exiv2-0.12, it doesn't work by default because
>>pkg-config can't find exiv2.
>>There's a workaround : add this in the script (with other exports) :
>>export PKG_CONFIG_PATH=$DIGIKAMDEST/lib/pkgconfig
>>I will add that on the digikam website
> Fabien, I've tried this, but no luck - configure still complains that there is 
> no exiv2 although the path $DIGIKAMDEST/lib/pkgconfig exists and there are 
> two files in there (exiv2.pc and libkipi.pc) ...
> I've deleted everything, 
> entered export PKG_CONFIG_PATH=$DIGIKAMDEST/lib/pkgconfig at the beginning of 
> both compile... files
> run compile_exiv2.sh, then compile_digikam.sh.
> no luck,
> again deleted everything, deleted the new export command from the 
> compile_exiv2.sh (but left it in compile_digikam.sh), still no luck.

Note, only compile_digikam.txt needs to be changed.
Could you try with the latest script and sent the one you used so we can 
check what's the problem ?

I hope you didn't put the export PKG_CONFIG_PATH *before* the definition 


More information about the Digikam-users mailing list