[Digikam-devel] In troubles compiling Digikam (0.9 from svn)

Caulier Gilles caulier.gilles at free.fr
Tue Jan 24 13:09:05 CET 2006


Le Mardi 24 Janvier 2006 10:22, fj.cruz at supercable.es a écrit :
> ---- fj.cruz at supercable.es escribió:
> > Hi everybody,
> >
> > I can't compile a fresh copy of Digikam (0.9) from svn. I've get this
> > error:
> >
> > digikam/showfoto/setup/Makefile.am: no rule to create target:
> > /home/pcruz/Desarrollo/test/digikam/utilities/setup/libshowfotosetup.la(.
> >/digikam/showfoto/setup/libsetup.la)
> >
> > I've a limeted experience with make files, so ... ideas?
>
> I've forgotten  to say that at home the app compiles without problems. As
> far I know, the only difference between home copy and office copy is that 
> at work i use unsermake instead make because when I did the first checkout
> of kde-admin , this was from "trunk" and not from "branches". I must to say
> that this has not been any problem until now.
>

Since yesterday morning, this makefile is in svn. You need to do make -f 
Makefile.cvs to re-check all folders and create all Makefile.in, etc...

About usermake, you can do want you want, but i has never used it and i 
recommend you to use automake/autoconf instead. Because i have no time to 
manage an another tool like usermake (and debug anymore)... i won't used this 
tool.

In the future, when digikam will be migrated to Qt4/KDE4, we will use 'scons' 
tool instead automake/autoconf (:=)))

Gilles


More information about the Digikam-devel mailing list