[Uml-devel] Various responses to various things ....

Luis De la Parra Blum lparrab at gmx.net
Mon Mar 17 11:20:37 UTC 2003

On Monday 17 March 2003 17:13, Brian Thomas wrote:
> 	I prefer rationalized naming of the variables as well. Attaching an "m_"
> 	for member variables, but why stop there? I see also in the code the
> 	schemes of "m_p"<Name> for member variable pointers to objects, and

I always use an "m" for member variables.. that way you can tell at a glanz if 
it's a member or a local variable, and you also prevent name conflicts..

 however, I think a balance between rationalizing names and convenience is 
necessary.. otherways you'll end up with something like
m_pvi<name> for a member that is a pointer to a vector of ints.... ok, so you 
get a pretty descriptve name (if you happen to know what all the letters 
mean), but it's a pain to write such a thing... remember: all excesses(??) 
are bad.


More information about the umbrello-devel mailing list