[Uml-devel] Various responses to various things ....

Brian Thomas thomas at mail630.gsfc.nasa.gov
Mon Mar 17 08:16:06 UTC 2003

On Monday 17 March 2003 09:35 am, umbrello-devel-request at mail.kde.org wrote:
> > Why?
> Well I find it quite handy to know at a glace if it's a local variable or
> a member one, especially in code that I'm not familiar with.  I suppose
> methods shouldn't be so big that it becomes an issue but in reality they
> are.  Why not?

	I prefer rationalized naming of the variables as well. Attaching an "m_"
	for member variables, but why stop there? I see also in the code the 
	schemes of "m_p"<Name> for member variable pointers to objects, and
	"m_n"<Name> for member variables which are primative numbers. Both
	are a good idea (IMO). There could be others as well in the code I missed..



This will be a memorable month -- no matter how hard you try to forget it.

More information about the umbrello-devel mailing list