[Uml-devel] Re: u2 plugins

Luis De la Parra Blum lparrab at gmx.net
Tue Mar 11 12:16:13 UTC 2003

On Tuesday 11 March 2003 20:05, Brian Thomas wrote:
> 	I think you should drop the "U" from the name of the umbrello classes.
> They should just be "application", "configurable", "plugin" and "tool". You
> can always supply the "umbrello" package name to the class in order to
> distinguish it properly (e.g. "umbrello::application".

I also think you sould drop the U and make them Umbrello::Application and 
Umbrello::Plugin instead.
that way you dont have name conflicts, and you can always use the namespace, 
certain classes or an alias so you dont have to write the whole thing if you 
dont want to


More information about the umbrello-devel mailing list