UI issues

Jared Breland jbreland at legroom.net
Fri Jan 31 15:20:14 GMT 2020

update on item 2: I think I'm running into a separate issue regarding
font size.  I reinstalled 3.2.3 from portage and get the same behavior
now.  I even tried rebooting to make sure it wasn't due to some cached
library or something.  So, either I'm running into a separate issue, or
I'm just mis-remembering.  Will look into that some more on my own.

Jared Breland
jbreland at legroom.net

On 1/31/20 1:56 AM, Jared wrote:
> I've run into a couple quirks with the UI.  I'm not sure if these are
> necessarily bugs, but I don't think it's intended behavior.
> 1. Tellico sometimes gets "stuck" on a particular item and doesn't
> update the item view when another item is selected from the Group View
> list.  While in this "stuck" state, if I select and try to update a
> different game, Tellico updates whichever previous game was selected
> and still displayed in the item view.  If I click on a different item
> in the Collection View list, that *does* update the item view, and
> then I can freely select other games in the Group View list again.
> I've encountered this issue multiple times but haven't reported it
> because I wasn't sure what causes it.  Updating a game seems to
> trigger it pretty reliably, though.  See if this lets you replicate it:
> a. Make sure you have both Group and Collection views enabled under
> Settings.
> b. Add a new game under an existing platform, with just title and
> platform entered
> c. Save, then select the game so it's shown in the item view
> d. Right-click on the game and update entry; after update, the full
> content should be displayed in the item view
> e. Click on another game in the Group View - if you've triggered the
> bug, the previous game you updated should remain displayed regardless
> of which other game you select
> f. Try Updating that new entry, and note that Tellico first updates
> the original item, then updates the currently selected item
> g. If you click on an item in the Collection View, it "fixed" the
> problem and lets you select any item again under the Group view
> 2. The font size of HTML-rendered text is /much/ smaller in this
> version.  See screenshot below for example.  In version 3.2.3, the
> rendered text was about the same size as the list and UI text.  Did
> you change anything relating to how text is rendered since 3.2.3?  If
> not, this may be related to compiling this myself and it linking
> differently against the KDE libraries (though I run Gentoo, so even
> with 3.2.3 portage compiled it and linked against the same libraries).
> Not a huge deal, but FYI.
> -- 
> Jared

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/tellico-users/attachments/20200131/5b8b3df1/attachment.html>

More information about the tellico-users mailing list