[Tellico-users] Tellico 2.9.91 Released ("3.0 beta1")

Rutger van Sleen djslash at djslash.org
Wed Apr 6 10:45:27 UTC 2016

Hi all,

I am using a Debian testing system with XFCE as my desktop environment.
There were a few things I needed to do before I could compile Tellico
from scratch. I do compile other (QT) stuff from time to time, so there
might be extra things needed on other systems. Below is my journey in
case it might benefit others.

First I installed the required libs from 
as mentioned in the COMPILING file. Note that this should probably be
updated to QT/KDE5 after version 3 has been released.

First thing I got was:
> CMake Error at CMakeLists.txt:9 (find_package):
>   Could not find a package configuration file provided by "ECM"
>   (requested version 1.3.0) with any of the following names:
>     ECMConfig.cmake
>     ecm-config.cmake

This was solved by installing the package 'extra-cmake-modules' (I was
first confused by thinking I needed package 'ecm', that happens to be on
version 1.03).

Next error was solved by installing qtbase5-dev:
> Could not find a package configuration file provided by "Qt5"
> (requested version 5.3.0)

Then I got a bunch of KF5 things, that I don't even going to paste here.
:p I just guessed the package names and installed them.

> $ sudo aptitude install libkf5archive-dev libkf5codecs-dev \
>    libkf5configwidgets-dev libkf5config-dev libkf5coreaddons-dev \
>    libkf5crash-dev libkf5guiaddons-dev libkf5i18n-dev \
>    libkf5iconthemes-dev libkf5jobwidgets-dev \
>    libkf5kdelibs4support-dev libkf5solid-dev libkf5wallet-dev \
>    libkf5xmlgui-dev

Originally I also included "libkf5doctools-dev libkf5kio-dev
libkf5widgetaddons-dev", but those weren't recognized. But with the
above, all necessary stuff got installed and CMake didn't stop with

Eventually I got:
> -- Generating done

\o/ Success!

Next step, compiling. This isn't mentioned in the docs, but I recommend
that you use the '-j' option to let 'make' use of all cores that your
CPU has (see `man make`).

It got to: [ 98%] Linking CXX executable tellico
> /usr/bin/ld: /usr/lib/x86_64-linux-gnu/libKF5KHtml.so.5.16.0:
>    undefined reference to symbol 'uncompress'
> //lib/x86_64-linux-gnu/libz.so.1: error adding symbols:
>    DSO missing from command line
> collect2: error: ld returned 1 exit status

And that's where I got stuck...

More information about the tellico-users mailing list