[Tellico-users] Amazon lookups stopped working

Keith A. Gillow Keith.Gillow at maths.ox.ac.uk
Sun Mar 4 11:16:13 UTC 2012

I see there is already a posting about Amazon JP ISBN lookups failing. I
am seeing a similar/the same problem with lookups on Amazon UK (and
Amazon US although I do not normally use that).

This could be related to the change to the Amazon Product Advertising
API on 21/2/2012. See


for details.

I recall that around September 2009 Amazon introduce the need for
individuals to sign up for their Product Advertising API in order to
perform lookups such as those done by Tellico. I duly signed up back
then and updated to Tellico 2.0 for the functionality.

The Amazon announcement mentioned above states:

"The new Product Advertising API interface definition (WSDL) is now
available. While your application may continue to operate after November
1, 2011 using older WSDLs, we will stop supporting all previous versions
on February 21, 2012. Please upgrade to the latest WSDL before that date
to ensure the continued operation of your application."

I successfully added a book in Tellico via an Amazon UK search on
15/2/2012 but when I next tried on 26/2/2012 and any time there after I
have no success.

I tried updating to Tellico 2.3.5 (built from source (+ patch from
http://tellico-project.org/tellico-235-released) on Ubuntu 10.04 LTS)
just in case some functionality changes were needed and had already been
introduced to versions of Tellico released after 1/11/2011 but I'm still
seeing the same problem.

When I try an ISBN search tellico just response with "the search
returned no items". If I try a person search (say Stephen King) then I
briefly see it say "results from amazon test 0/4356" before again saying
"the search returned no items". So I think Tellico is performing an
Amazon search but perhaps due to the API change it is not getting back
results in the form it expects.



More information about the tellico-users mailing list