[Tellico-users] Re: Tellico Namespace Errors When Searching the Z39.50 ADS Server

Nathan Clarke N.Clarke at curtin.edu.au
Thu Feb 3 04:45:39 UTC 2011

Hi Robby,

Well done and thank you for resolving this.  And from the email thread 
you referenced it seems that the ADS administrators have been notified 
of the bug/s, so hopefully they will fix it at their end, one day ... 
though I see the last post was Nov 2007, so maybe not...

I do not need to use this feature right away, but if I do, I'll try your 
script; otherwise I'll wait for the next release.

Thanks again.


On 02/02/11 18:08, Robby Stephenson wrote:
> So here's what I can tell you. The XML returned from the ADS server is
> invalid, which is why Tellico was choking on it. Rather than trying to fix it
> up (which would be slightly ambiguous), I implemented a reader in Tellico
> for the native ADS format from their z39.50 server. I just checked it into
> the Tellico source tree so it'll be in the next release.
> For current releases, there doesn't appear to be a way to access the ADS
> through z39.50 in a standard way. You can try using the script I wrote,
> which grabs the bibtex data for searches, or you can just wait until Tellico
> 2.3.3 is out, which I could push by the end of the month, perhaps.
> For an email chain for the BibDesk app for Macs that deals with the same
> issue, see http://www.mail-archive.com/bibdesk-
> users at lists.sourceforge.net/msg01183.html
> Robby
> On Monday 31 January 2011, Nathan Clarke wrote:
>> Hi Robby,
>> Thanks for taking some time to look at this.  The options I have are:
>>     * Source type: z39.50 Server
>>     * The "Updating from source should overwrite user data" box is not
>> checked.
>>     * Available Fields boxes for Address, Abstract and Illustrator are
>> all checked (though I've tried various combinations of this to no
>> effect). * The "Use preset server" box is not checked.
>>     * Host: z3950.adsabs.harvard.edu
>>     * Port: 210
>>     * Database: AST
>>     * Character set: utf-8 (I've tried all of these to no effect too)
>>     * Format: MODS
>>     * User: [none set]
>>     * Password: [none set]
>> Cheers,
>> Nathan
>> On 31/01/11 22:02, Robby Stephenson wrote:
>>> Hi Nathan,
>>> I apologize for the late reply.
>>> You're right, it does appear to be a namespace issue. The z39.50
>>> searching goes through a somewhat complicated process of being
>>> converted from MODS to MARC to XML, so there are certainly plenty of
>>> points where the XSLT can get hairy.
>>> What are the options you're using for the ADS z39.50 target so I can do
>>> some testing myself? (database name, character set, etc.?)
>>> In the meantime, though it's not as flexible, you could take a shot
>>> using a script I wrote a while back, if you were interested.
>>> http://tellico-project.org/search-saonasa-astrophysics-data-system
>>> Robby
>>> On Wednesday 12 January 2011, Nathan Clarke wrote:
>>>> In Tellico's data source properties, I added a new Z39.50 data source
>>>> for the ADS Astronomy Database (hosted on z3950.adsabs.harvard.edu).
>>>> However, when I attempt to perform a search (using key words that I
>>>> know are in the ADS data base), I get no results, and in the shell
>>>> (from where I launched Tellico) I see lots of error messages of the
>>>> form below:
>>>> namespace error : Namespace prefix dc on description is not defined
>>>> n>http://adsabs.harvard.edu/abs/2011AAS...21714304M</dc:relation><dc:d
>>>> esc ription
>>>> I am no XML expert, but this appears to be some sort of XML namespace
>>>> issue.
>>>> Can you offer any advice on this?  Is there any way that I can fix it?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: N_Clarke.vcf
Type: text/x-vcard
Size: 393 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/tellico-users/attachments/20110202/e66ee746/attachment.vcf>

More information about the tellico-users mailing list