Help Compiling Taglib: missing 'config.h'

Lukáš Lalinský lalinsky at
Wed Jul 20 22:08:52 CEST 2011

On Wed, Jul 20, 2011 at 8:06 PM, Pris Matic <prismatic.project at> wrote:
> Hi all,
> I'm trying to compile TagLib using Qt Creator in Ubuntu 10.10. I run into
> the following error:
> 'config.h: No such file or directory    id3v2frame.cpp'
> The line in question is an #include statement that's called when ZLIB
> doesn't exist:
> #include <config.h>
> What's this file referring to? I feel like it's pointing to some system file
> since its enclosed in <> but I don't know. The TagLib source does not
> include a config.h. I tried 1.7 and the latest version up on git. I've
> included my *.pro file (this is for the latest version off github). I'd
> appreciate any help in getting taglib to compile.

The file is generated by CMake and should be included only if the
HAVE_CONFIG_H macro is defined. This wasn't the case in two files, and
they were including the file if HAVE_ZLIB was *not* defined. This is
now fixed in git, but as a workaround you can create an empty config.h


More information about the taglib-devel mailing list