"memory not mapped" error during system() call

meik michalke meik.michalke at uni-duesseldorf.de
Sun May 6 18:27:01 UTC 2018


Am Sonntag, 6. Mai 2018, 19:08:43 CEST schrieb Thomas Friedrichsmeier:
> > if i run the same code from a plain R session, it just works like it
> > should:
> [...]
> > so i guess it's an issue with RKWard's R console, maybe?
> I'd be very surprised if it was. After all, this is even in a
> completely separate process (going via system()). What could play a
> role is some subtle difference in env vars (and RKWard could play a
> role, there). Noteably, perhaps LD_LIBRARY_PATH?

very helpful guess! it wasn't LD_LIBRARY_PATH but R_LIBS_USER -- the process 
tried to use packages built for R 3.5 with R 3.4. once the variable was unset 
it was running again. thanks!

viele grüße :: m.eik

  dipl. psych. meik michalke
  institut f"ur experimentelle psychologie
  abt. f"ur diagnostik und differentielle psychologie
  heinrich-heine-universit"at d-40204 d"usseldorf
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/rkward-devel/attachments/20180506/75297972/attachment.sig>

More information about the rkward-devel mailing list