[rkward-devel] paginate onscreen graphics device

Prasenjit Kapat kapatp at gmail.com
Mon Jul 5 18:19:16 UTC 2010


Hi,

On Mon, Jul 5, 2010 at 1:44 PM, Thomas Friedrichsmeier
<thomas.friedrichsmeier at ruhr-uni-bochum.de> wrote:
> Hi,
>
> On Monday 05 July 2010, Prasenjit Kapat wrote:
>> Except one: creation time / main title! I couldn't find a way to get
>> anything out of the return value of recordPlot ().
>
> ok, well, this was just an idea.

I will dig into other ways to get around, time permitting.

> I just understood the "add to history"-action from the comments
> in your R code. I had assumed that it always appends to the end of the
> history, and both the icon, and the label of the action convey that idea. In
> fact it replaces a plot in the history (although, when at the end of the
> history, the effect is similar).

It does two things, depending on the situation (kind of 'operator overloading'):

1. If the plot that is displayed on the device is new (ie, it hasn't
been added to the history, yet), then "add to history" will _add_ (not
replace) this plot to the history.
(The history length will increase if the current length is less than
the max_length, otherwise, remain the same.)

2. If the plot that is displayed on the device is old (ie, it was
added to the history earlier) then "add to history" will _replace_
this old plot by the one currently displayed. (This will _not_ change
the history length.)

The case for point 2 (as you may have read from the comments) is: if
you go back / fwd in history and modify the displayed plot by calls
such as points (), lines (), text (), etc... then "add to history"
will replace the old one by the modified one. The modified plot is not
a "new" plot in the sense that plot.new () hasn't been called.

The case for point 1: well, it is obvious. If the currently displayed
plot was generated by a plot.new () call then it is a "new" plot and
"add to history" should _add_ to history.

> So we should come up with a better label/icon.
> IIRC you called it "Current plot", initially, but at least for me, that did
> not get the idea across. Ideas?

Yes, I'm not too sure what to call it? 'Save to history'? It would be
wrong to call it, 'Append to history' for sure.

Or do you suggest to split off the above two cases into two distinct
icons / menu items? One (corresponding to 1) could be named 'Append to
history' and two (cor. to 2) could be called 'Overwrite' or 'Replace'?

Or, if you can add rk.ask.yesnocancel (...) function, then, instead of
replacing, we could ask the user for (a) append or (b) overwrite. But
that may seem like too many pop ups....

Regards,
-- 
Prasenjit




More information about the Rkward-devel mailing list