[rkward-devel] RKWard 0.5.0c-test5

stfs stfs at fs-analyse.dk
Mon Mar 30 14:55:03 UTC 2009

On 2009-03-30 15:08, meik michalke wrote:
> hi finn,
> thanks for looking after it!
> Am Montag 30 März 2009 13:11:02 schrieb stfs:
>> Compiling now works.
> that's a relief :-)
>> I first installed it the '.deb' way (ie. making the deb and double click
>> it).
>> Rkward could be started from command line but not from menu. Menu had no
>> icon.
>> I believe the reason is that /usr/local/bin/rkward does not exist.
> if you're looking for something to be installed in /usr/local i wonder how you 
> created the .deb package? did you use the diff i created for hardy?
>  o http://reaktanz.de/stuff/R/rkward_0.5.0c-test5-1~hardy1.diff.gz
>    (see below how to apply it)
> what does the command "which rkward" return?
immediately after the .deb install it returned nothing.
After source install it returned /usr/local/bin/rkward
> in general, if you compile software from source via make or something similar, 
> it usually gets installed in /usr/local/(bin|share|lib...), to not mess up the 
> distribution's installation (i.e. overwriting files that belong to a package, 
> "make install" will not warn you if it does so). official distribution 
> packages on the other hand usually install to /usr/(bin|share|lib...), so do 
> the .deb packages thomas is providing. moreso, a .deb should *not* install to 
> /usr/local, to not overwrite your own compiled programs. you could say, 
> everything in /usr/local is your personal playground, and debian packages 
> should stick to /usr instead.
> the trouble especially with ubuntu 8.04 is that rkward 0.5.0 is a kde4 
> application, and that this version of ubuntu expects the installation of all 
> kde4 stuff to /usr/lib/kde4/(bin|share|lib...) -- that's why you had to add 
> that to your PATH prior to compilation, because it is not a common path... 
> (ubuntu 8.10 puts everything in /usr again, so we're not in any path trouble 
> there).
> alltogether, you should look for the rkward binary in /usr/lib/kde4/bin, and 
> check if the menu entry tries to start /usr/lib/kde4/bin/rkward (with full 
> path). this actually should be accomplished by the diff above:
>  - get rkward_0.5.0c-test5.orig.tar.gz from
>    http://rkward.sourceforge.net/temp/
>  - get rkward_0.5.0c-test5-1~hardy1.diff.gz from above
>  - tar xzvf rkward_0.5.0c-test5.orig.tar.gz
>  - cd rkward_0.5.0c-test5
>  - zcat ../rkward_0.5.0c-test5-1~hardy1.diff.gz | patch -p1
>  - chmod a+x debian/rules
>  - export PATH=$PATH:/usr/lib/kde4/bin
>  - fakeroot dpkg-buildpackage -b -D
>  - dpkg -i ../rkward_0.5.0c-test5-1~hardy1_i386.deb
> have you tried to install the precompiled ubuntu .deb yet?
>  o http://reaktanz.de/stuff/R/rkward_0.5.0c-test5-1~hardy1_i386.deb
After uninstalling everything rkward and deleting everything with rkward 
in it I tried but it says
'Dependency is not satisfiable: kdelibs5'

"apt-get install kdelibs5*"
but get a host of unmet dependencies

The deb made from Thomas' instructions installs but is showing the same 
problem as before:
It wants to launch 'rkward' but finds nothing and has no icon.

'which rkward' returns nothing

rkward will not start from menu or command line
(the reason it starts from command line for some is, of course, that 
they use the same console they used to compile so the path contains 

Starting it directly with "/usr/lib/kde4/bin/rkward" seems to be 
working. No complaints and everything seems ok.

>> Finally I found the 'deleted' menu as an xdg-file in
>> ~/.local/share/applications/ as soon as I deleted it from there it
>> turned up in the menu with an icon and working too.
> whenever you change a menu setting, a local copy with those changes will be 
> createrd in ~/.local/share/applications/, which will then be used instead of 
> the system files. please make sure that there isn't any rkward file left here 
> to test if the system wide installation works.
>> Right now I think there may be a problem with the .deb (it does not
>> appear to create /usr/local/bin/rkward).
> as explained above, it's not supposed to ;-)
>> This file was created by source install instead.
> which is correct, but not for the .deb file. could you give the precompiled 
> version another try or test the compilation as described above?
> viele gruesse :: m.eik

Thanks for all the infomation and know that I, as a user, is deeply 
greatfull for the work you and the other devs are doing.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/rkward-devel/attachments/20090330/9483f015/attachment.html>

More information about the Rkward-devel mailing list