[rkward-devel] Compiling rkward on ubuntu 8.04

Matthieu Stigler matthieu.stigler at gmail.com
Mon Mar 9 14:34:26 UTC 2009

Thanks Meik!!

Thanks to your advice I could find how to call kde4-config, as I'm on Ubuntu
it is on an other path:
dpkg -S kde4-config
kde4libs-bin: /usr/lib/kde4/bin/kde4-config
kdelibs5-data: /usr/share/man/man1/kde4-config.1.gz

So I run: cmake  -DCMAKE_INSTALL_PREFIX=`/usr/lib/kde4/bin/kde4-config
--prefix` ../
 which could work.

Unfortunately a second problem arose, which is probably much worst :-( :

 Found at /usr/share/R/include/R.h
-- Checking for existence of libR.so
-- Exists at /usr/lib/R/lib/libR.so
-- Checking whether we should link against libRlapack.so
-- No, /usr/lib/R/lib/libRlapack.so does not exist
-- Checking whether we should link against libRblas.so
-- No, /usr/lib/R/lib/libRblas.so does not exist
-- Checking for R package library location to use
-- Will use /usr/local/lib/R/site-library

So with cmake I had following error message at the end:
[ 97%] Building CXX object rkward/CMakeFiles/rkward.bin.dir/robjectbrowser.o
/home/baia/rkward/rkward/rkward/robjectbrowser.cpp:254:2: warning: #warning
this will never work, as the object browser is active in this case!
[ 98%] Building CXX object rkward/CMakeFiles/rkward.bin.dir/robjectviewer.o
[ 99%] Building CXX object rkward/CMakeFiles/rkward.bin.dir/rkconsole.o
[ 99%] Building CXX object
Linking CXX executable rkward.bin
/usr/bin/ld: cannot find -lphonon
collect2: ld returned 1 exit status
make[2]: *** [rkward/rkward.bin] Error 1
make[1]: *** [rkward/CMakeFiles/rkward.bin.dir/all] Error 2
make: *** [all] Error 2

So I can't launch rkward:
/usr/bin/rkward.bin: error while loading shared libraries: libRlapack.so:
cannot open shared object file: No such file or directory

This is a problem I already had... see post on r-sig-debian "Update to 2.8
and problem with liblapack
november 2008. This happened for special packages (Matrix, linpack) but was
solved by compiling them myself. I reported a bug but it did not had

Does any of one has ideas how I could solve that? Seems difficult... thanks
a lot for your help!!

2009/3/9 meik michalke <Meik.Michalke at uni-duesseldorf.de>

> On Monday 09 March 2009 13:35:55 Matthieu Stigler wrote:
> > Should I have kde4-config? It seems it is not a package, where can I
> > have it from?
> in kubuntu 8.10, kde4-config is part of the package kdelibs-bin. you can
> use
> the command "dpkg -S kde4-config" to scan all known packages for that file
> (or
> any other file, of course ;-)). notice that the "-S" is a *capital* letter:
>  m at chiana ~ $ dpkg -S kde4-config
>  kdelibs-bin: /usr/bin/kde4-config
>  kdelibs5-data: /usr/share/man/man1/kde4-config.1.gz
> hth :: m.eik
> --
>  dipl. psych. meik michalke
>  abt. f"ur diagnostik und differentielle psychologie
>  institut f"ur experimentelle psychologie
>  heinrich-heine-universit"at d"usseldorf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/rkward-devel/attachments/20090309/ae2af04d/attachment.html>

More information about the Rkward-devel mailing list