[rkward-devel] Installation problem using Ubuntu and some suggestions

Stefan Roediger stefan_roediger at gmx.de
Mon Jul 2 17:04:24 UTC 2007

Am Montag, 2. Juli 2007 13:35:24 schrieb Matthieu Stigler:
> Hello
> I want first to thank you very much for you work! I used much SPlus on
> Windows and now with Ubuntu is R interesting but too complicate to use
> without graphical interface... So your program RKward is really
> interesting and useful! Thanks a lot and please continue it!

Thanks for the charming words. Our main developer is off-line for a couple of 
days. Anyway, he will be very pleased to hear you comment. And for sure, we 
will continue it. ;)

> _*Bug*_
> I had problem for the installation of RKward on Ubuntu. Maybe is it
> because you made it for KDE?

No, generally it's known to run also on GNOME. If there are good packages from 
Ubuntu everything should work. But Ilias has the better insight here.

> -using the synaptic package manager to download the 0.4.2-2 version, I
> have:
> ---------------------------------------------------------------------------
>-------------------------------------------------------- mat at openedwin:~$
> rkward &
> [1] 11890
> mat at openedwin:~$ X Error: BadDevice, invalid or uninitialized input
> device 169
>   Major opcode:  145
>   Minor opcode:  3
>   Resource id:  0x0
> Failed to open device
> X Error: BadDevice, invalid or uninitialized input device 169
>   Major opcode:  145
>   Minor opcode:  3
>   Resource id:  0x0
> Failed to open device
> Debug-flags as decimal: 8191
> kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x81dcc48 ):
> KAccel object already contains an action name "window_close"
> R version 2.4.1 (2006-12-18)
> Copyright (C) 2006 The R Foundation for Statistical Computing
> ISBN 3-900051-07-0
> R est un logiciel libre livré sans AUCUNE GARANTIE.
> Vous pouvez le redistribuer sous certaines conditions.
> Tapez 'license()' ou 'licence()' pour plus de détails.
> ...
> ---------------------------------------------------------------------------
>----------------------------------------- But I can run Rkward and use it!
> -trying to download the 0.4.7 version direct from the site, I have the
> following message (see attached document):
> "Error: dependency is not satisfiable: r-base-core"
> An so I was unable to obtain the latest version :-(

At least RKWard 0.4.7 requires R > 2.5.x. Please consider this if you intend 
to compile from source (obviously the same applies if you install a deb 
package). Here is a link about compiling RKWard:

In Ubuntu forums is a thread related to your problem:
Maybe this is of help.

> _*
> Suggestion*_
> -This is not really a bug, but either a suggestion:
> I was unable to copy the "command lines" from the command log window,
> the "edit" menu is unavailable for the command log windows, while it is
> available for the others. This seems to me to be important, so you can
> copy the command lines obtained from the plug-ins into a script.
> -Could you integer the xlsReadWrite package? This is unfortunately only
> available for Windows but is a very useful function!
> Thanks a lot!
> Matthieu

I second the reply from Ilias. I checked for xlsReadWrite via RKWard and found 
version 1.3.2 to be there ready for download, thus it should also be 
available for Linux.
Your commad files copy request should also be solved (I run 0.4.7a-1



More information about the Rkward-devel mailing list