Requiring Qt 5.15 for KDE Frameworks 5?

David Faure faure at
Sat Mar 27 13:11:38 GMT 2021

On samedi 27 mars 2021 12:51:37 CET Kai Uwe Broulik wrote:
> Hi everyone,
> during the ongoing KDE Frameworks 6 sprint we were just contemplating
> whether we can bump the required Qt dependency for Frameworks 5 to Qt 5.15.
> Reason being that Qt 5.15 includes a set of porting aids and
> forward-compatibility with Qt 6, such as version-less "Qt" rather than
> "Qt5" CMake target, various QStringView-related features, and so on.
> We would like to start working on KDE Frameworks 6 on Qt 6 but still
> keep Frameworks 5 supported with as little overhead as possible, i.e.
> not having a gazillion ifdefs or even dedicated branch, which we would
> likely need, should we have to continue supporting Qt 5.14 in the process.
> Are there any objections or concerns or potential release schedule
> conflicts if we did that?

While at it, can we also get your feedback on
* Requiring C++17
* Requiring CMake >= 3.16

Obviously this only matters for distributions that update KF5 every month.

David Faure, faure at,
Working on KDE Frameworks 5

More information about the release-team mailing list