KDEPIM (16.12) and Gpgme minimum requirement

Andreas Sturmlechner andreas.sturmlechner at gmail.com
Sun Nov 6 22:07:04 UTC 2016


On Thursday, 3 November 2016 at 11:45, Sandro KnauƟ wrote:
> You may got the notice, that the cpp(gpgme++) and qt (QGpgme) interface, 
> previously build by KDEPIM in the libgpgmepp package, moved down to GpgME 
> directly. That's why KDEPIM depends on very recent GpgME.
> 
> Together with Andre we came to the conclusion, that we want to support:
> 
> GpgME >= 1.7.1

This decision also affects kde-runtime (more specifically, kwalletd-4), which 
is still released as part of KDE Applications even in 16.12. kwalletd (when 
built with gpg support) to this date is depending on the gpgmepp version of 
kdepimlibs-4, which is now conflicting with >=Gpgmepp-1.7.0. But someone has 
been working on a patch to port it to Gpgmepp as well:

https://git.reviewboard.kde.org/r/129339/

I think it would make a lot of sense to get it in for 16.12.

Regards,
Andreas


More information about the release-team mailing list