KDEPIM (16.12) and Gpgme minimum requirement

Sandro Knauß sknauss at kde.org
Thu Nov 3 10:45:47 UTC 2016


Together with Andre Heinecke (developer of gpgme), we discussed the minimum 
version of GpgME we want to support with the upcoming release of KDEPIM for 
Applications 16.12. 

You may got the notice, that the cpp(gpgme++) and qt (QGpgme) interface, 
previously build by KDEPIM in the libgpgmepp package, moved down to GpgME 
directly. That's why KDEPIM depends on very recent GpgME.

Together with Andre we came to the conclusion, that we want to support:

GpgME >= 1.7.1

We can't support 1.7.0 because the API is not complete in this version, to 
support KDEPIM. 1.7.2 will be released hopefully next week and will clean up 
some things and extend the API again (moved things from libkleo -> gpgme), but 
it is ABI compatible with 1.7.1.

For KDE Applications 17.04 we will raise the minimum version very certainly 
again, to get rid of copies in libkleo.


Sandro Knauß
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/release-team/attachments/20161103/718e4312/attachment.sig>

More information about the release-team mailing list