release libkgapi

David Faure faure at kde.org
Sun Jul 24 09:19:51 UTC 2016


On samedi 23 juillet 2016 14:27:35 CEST Sandro KnauƟ wrote:
> Hey Dan,
> 
> libkgapi is not part of KDE Applications, so you need to release it
> separately.

Shouldn't we make it part of the KDE Applications release instead ?

This would make things much simpler for compiling KDEPIM.

The fact that it's separate also just gave me an issue when trying to switch
all modules defined in kf5-kdepim-build-include to Applications/16.08.
That one module doesn't have such a branch, breaking my build (OK prison 
doesn't either but for that one we have a plan, moving it to KF5).

IMHO extragear is stuff that is "on top" of KF5 + KDE Applications.
Having KDE Applications depend on extragear seems circular (or at least wrong 
layering) to me. Unless maybe I'm missing recent developments about 
extragear's role, everything above KF5 is a bit of a blur to me ;)

-- 
David Faure, faure at kde.org, http://www.davidfaure.fr
Working on KDE Frameworks 5



More information about the release-team mailing list