KDE Applications 15.08 RC is out

Eric Hameleers alien at slackware.com
Fri Aug 28 14:41:19 UTC 2015

On Mon, 10 Aug 2015, Rex Dieter wrote:

> Rex Dieter wrote:
>> Rex Dieter wrote:
>>> Raymond Wooninck wrote:
>>>> On Thursday 06 August 2015 22:21:52 Albert Astals Cid wrote:
>>>>> I failed to use the proper CC when publishing it in kde.org this
>>>>> afternoon.
>>>>> Any feedback? Is anyone actually compiling this or the Beta packages?
>>>> Hi Albert,
>>>> I have compiled KDE Applications 15.08 RC for openSUSE and have the
>>>> following failures:
>>>> 1)	libkgeomap will no longer compile as that it requires the
>>> Qt4/KDE4
>>>> version of Marble, but Marble is now Qt5/KF5 based.
>>> It's been possible to ship both Qt4 and Qt5 based libmarblewidget for
>>> awhile, but it seems that marble devs disabled Qt4 support only recently.
>> Sorry, this statement of mine was incorrect... it is still possible to
>> build both Qt4 and Qt5 versions from the latest marble sources (seems the
>> methodology changed, I'll sort that out with marble devs and report back
>> on the details).
> We came up with a quick fix,
> http://quickgit.kde.org/?p=marble.git&a=commit&h=5a7b3daeaab324c2c6f3ffdba69a14dc959b3331
> So subsequent marble builds that include that commit will build for Qt5 (by
> default), and for Qt4 if you set 'cmake -DQT5BUILD=OFF'
> -- Rex

I tried "-DQT5BUILD=OFF" and a lot more.
No matter what I try, the moc from Qt5 eventually gets picked and I 
end with errors "this file was generated using the moc from 5.5.0".

I tried this in addition:
- explicitly setting -DQT4BUILD=ON
- explicitly setting -DQT_QMAKE_EXECUTABLE to the Qt4 qmake path
- explicitly setting -DQT_MOC_EXECUTABLE to the Qt4 moc path
- setting PATH to just the Qt4 bin directory, /usr/bin and /bin
and to no avail.
I do not know what configuration file determines the moc that's being 
When cmake completes its configuration I find always (using cmake 
-L) that:

No mention of QT4BUILD at all. And the CMakeFiles.txt suggests that 
WITH_KF5 should have been set to OFF instead of ON.

Any ideas? With this, I can not ship a Qt4 based marble and 

Cheers, Eric

Eric Hameleers <alien at slackware.com>
Home: http://alien.slackbook.org/blog/

More information about the release-team mailing list