Review Request 124801: set cmake_min_req to match kdelibs policy and enable newer cmake policies

Heiko Becker heirecka at
Tue Aug 18 09:55:49 UTC 2015

This is an automatically generated e-mail. To reply, visit:

Review request for Release Team and Urs Wolfer.

Repository: krdc


This is just a cherry-pick of c8789dd6546c8fd8d00e4c0ed1ac8fa48d337acf from master. With the recent cmake changes to kdelibs>4.14.10 krdc fails to build with newer cmake versions with the error below. Adding the release-team, because it touches a dependency requirement and this patch might be nice to have in the 15.08.0 tarball.

  * In program cave perform install --hooks --managed-output --output-exclusivity with-others =kde/krdc-15.08.0:4::kde --destination installed --replacing =kde/krdc-15.08.0:4::installed --x-of-y 1 of 1:
  * When installing 'kde/krdc-15.08.0:4::kde' replacing { 'kde/krdc-15.08.0:4::installed' }:
  * When running an ebuild command on 'kde/krdc-15.08.0:4::kde':
  * Install failed for 'kde/krdc-15.08.0:4::kde' (paludis::ActionFailedError)

-- Configuring incomplete, errors occurred!
See also "/var/tmp/paludis/build/kde-krdc-15.08.0/work/build/CMakeFiles/CMakeOutput.log".
See also "/var/tmp/paludis/build/kde-krdc-15.08.0/work/build/CMakeFiles/CMakeError.log".
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:112 (elseif):
  given arguments:

    "VERSION_LESS" "3.1"

  Unknown arguments specified
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:501 (_pkgconfig_parse_options)
  /usr/share/cmake/Modules/FindOpenSSL.cmake:43 (pkg_check_modules)
  /usr/share/apps/cmake/modules/Qt4ConfigDependentSettings.cmake:224 (FIND_PACKAGE)
  /usr/share/apps/cmake/modules/FindQt4.cmake:1207 (INCLUDE)
  /usr/share/apps/cmake/modules/FindKDE4Internal.cmake:395 (find_package)
  /usr/share/cmake/Modules/FindKDE4.cmake:108 (find_package)
  CMakeLists.txt:6 (find_package)

CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 3.3)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.


  CMakeLists.txt 26417cf89c5bf54283be4c03b642d280e62758c2 



Successfully built against kdelibs-4.14.11 and cmake 3.3.1.


Heiko Becker

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the release-team mailing list