can kdebase-4.5.4 depend on kdelibs >= 4.5.4?

Sebastian Kügler sebas at
Mon Nov 29 14:43:12 CET 2010

On Saturday, November 27, 2010 22:25:46 Jonathan Riddell wrote:
> On Sat, Nov 27, 2010 at 03:22:32PM -0600, Rex Dieter wrote:
> > On 11/27/2010 01:29 PM, Chani wrote:
> > > [please CC]
> > > 
> > > erk. I just backported a bugfix to 4.5 - but it needs a new function in
> > > kdelibs. which makes kdebase depend on 4.5.4 for that function.
> > > but, ade tells me that it might not be allowed to depend on anything
> > > more than 4.5.0.
> > > is this true? :/  ('cause then I'll have to revert. wah.)
> > 
> > Personally, I'm ok with it.
> > 
> > After a quick hunt through, I was unable to find
> > anything that strictly forbids this.  I'm fairly certain I recall
> > precedent of this being done in the past as well.
> We have no policy.  I drafted this a while ago but it didn't go
> anywhere because there doesn't seem to be consensus.

My understanding is that the freezes are kept in place, so that the same API 
changes that are disallowed in the late beta phase of a release are also not 
allowed for minor updates. The reason is that we should not touch binary 
compatibility or even source compatibility in minor releases.

This is in line with the reasoning from the wikipage Jonathan posted, which I 
think makes sense and are reasonable practice.

At least not if there's not a very good reason to do it. :)

So: What kind of bugfix is this? How critical is it to have it in 4.5.4? If 
it's not too critical, I'd exclude both API change and bugfix from 4.5.4 and 
only apply it to trunk.
sebas | | GPG Key ID: 9119 0EF9

More information about the release-team mailing list