D24049: add tooltips to the intro page

Nathaniel Graham noreply at phabricator.kde.org
Wed Sep 18 15:06:39 BST 2019


ngraham added a comment.


  In general +1

INLINE COMMENTS

> SidebarMode.cpp:581
>  
> +    d->toolTipManager = new ToolTipManager(d->searchModel, d->quickWidget, false);
> +    d->subCategoryToolTipManager = new ToolTipManager(d->subCategoryModel, d->quickWidget, false);

Is there a strong reason to move these around?

> tooltipmanager.h:48
>      */
> -    explicit ToolTipManager(QAbstractItemModel *model, QWidget* parent);
> +    explicit ToolTipManager(QAbstractItemModel *model, QWidget* parent, bool centered);
>      ~ToolTipManager() override;

Use an Enum here instead of a bool to improve readability. See for example https://codereview.stackexchange.com/questions/11300/boolean-enums-improved-clarity-or-just-overkill

REPOSITORY
  R124 System Settings

REVISION DETAIL
  https://phabricator.kde.org/D24049

To: tienisto, #vdg, ngraham, GB_2
Cc: plasma-devel, LeGast00n, The-Feren-OS-Dev, jraleigh, fbampaloukas, GB_2, ragreen, ZrenBot, himcesjf, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20190918/643ecdc6/attachment-0001.html>


More information about the Plasma-devel mailing list