D9848: Updated the blur method to use the more efficient dual kawase blur algorithm.
Alex Nemeth
noreply at phabricator.kde.org
Tue Jan 16 02:33:50 UTC 2018
anemeth added inline comments.
Restricted Application edited projects, added KWin; removed Plasma.
INLINE COMMENTS
> fredrik wrote in blur.h:41
> This number could use an explanation.
I don't know why it's 5
This was in the old blur too: https://github.com/KDE/kwin/blob/master/effects/blur/blur.cpp#L503
I just move this number to a variable.
> fredrik wrote in blurshader.h:95
> I think you could simplify the code quite a bit by having an array of
>
> struct {
> GLShader *shader;
> int mvpMatrixLocation;
> ...
> };
>
> and use m_activeSampleType as an index into that array.
Only the downsample and upsample have the same uniforms, copysample uses different ones.
This means that it would be an array with only 2 elements (up and down sample).
I think it's unnecessary to create an array with only 2 elements.
REPOSITORY
R108 KWin
REVISION DETAIL
https://phabricator.kde.org/D9848
To: anemeth, #plasma, #kwin
Cc: luebking, broulik, romangg, zzag, anthonyfieroni, mart, davidedmundson, fredrik, ngraham, plasma-devel, kwin, #kwin, iodelay, bwowk, ZrenBot, progwolff, lesliezhai, ali-mohamed, hardening, jensreuterberg, abetts, sebas, apol
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20180116/76543d25/attachment.html>
More information about the Plasma-devel
mailing list