D14988: Implement option to toggle page navigation wraps around for pager plasmoid

David Edmundson noreply at phabricator.kde.org
Tue Aug 28 11:29:26 BST 2018


davidedmundson added inline comments.

INLINE COMMENTS

> main.qml:130
> +                    (pagerModel.currentPage + 1) % repeater.count : pagerModel.currentPage + 1;
> +                if (nextPage >= repeater.count) nextPage = repeater.count - 1;
> +                pagerModel.changePage(nextPage);

would

  var nextPage = plasmoid.configuration.wrapPage?
                    (pagerModel.currentPage + 1) % repeater.count :
                     Math.max(pagerModel.currentPage + 1, repeater.count)

be more readable?

REPOSITORY
  R119 Plasma Desktop

REVISION DETAIL
  https://phabricator.kde.org/D14988

To: phuongn, #plasma, #vdg
Cc: davidedmundson, broulik, plasma-devel, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20180828/5dbd2521/attachment.html>


More information about the Plasma-devel mailing list