D8309: Modernize: Use nullptr where possible

Kai Uwe Broulik noreply at phabricator.kde.org
Sun Oct 15 12:31:58 UTC 2017


broulik accepted this revision.
broulik added inline comments.
This revision is now accepted and ready to land.

INLINE COMMENTS

> backtracegenerator.cpp:69
>      //they should always be null before entering this function.
> -    Q_ASSERT(m_proc == NULL && m_temp == NULL);
> +    Q_ASSERT(m_proc == nullptr && m_temp == nullptr);
>  

`Q_ASSERT(!m_proc && !m_temp)`?
iirc Clang doesn't like comparisons to `nullptr` very much (at least in `QCOMPARE`) and I find it cleaner

> crashedapplication.cpp:98
>      std::free(savedLocale);
> -    return QString::fromLocal8Bit(name != NULL ? name : "Unknown");
> +    return QString::fromLocal8Bit(name != nullptr ? name : "Unknown");
>  #else

`name ? name : "Unknown"`?

> drkonqi.cpp:83
>  {
> -    static DrKonqi *drKonqiInstance = NULL;
> +    static DrKonqi *drKonqiInstance = nullptr;
>      if (!drKonqiInstance) {

could be simplified to `static DrKonqi *drKonqiInstance = new DrKonqi();` or even created on the stack and return address (just noticed, not what this patch is about obviously)

REPOSITORY
  R871 DrKonqi

BRANCH
  master

REVISION DETAIL
  https://phabricator.kde.org/D8309

To: kfunk, sitter, broulik
Cc: broulik, plasma-devel, ZrenBot, progwolff, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20171015/0b770e99/attachment.html>


More information about the Plasma-devel mailing list