signal messageButtonPressed(const Plasma::MessageButton button);

Aaron J. Seigo aseigo at
Sat Feb 12 19:40:10 CET 2011

On Saturday, February 12, 2011, Marco Martin wrote:
> On Friday 11 February 2011, Aaron J. Seigo wrote:
> > On Tuesday, February 8, 2011, Marco Martin wrote:
> > > Hi all,
> > > I see in Plasma::Applet that
> > > void messageButtonPressed(const MessageButton button);
> > > was changed in
> > > void messageButtonPressed(const Plasma::MessageButton button);
> > 
> > that sucks; specifying Plasma:: in the signature is absolutely required
> > for it to be expected to work consistently. the only way for
> > non-namespaced params to work in signals like this is if plasmoid
> > writers include a "using Plasma" statement in their code which does a
> > lot to invalidate the point of having a namespace in the first place.
> > 
> > i suppose we can move back in this case, but it's really, really, really
> > something we need to make consistent in libplasma2 as it is a source of
> > ongoing annoyances.
> to me honestly if it's ok for the only real user that i know of that we
> have right now of this particular feature, we can really leave it changed
> with the proper namespace ;)

ok, that's good then :)

so it's just the lesson gong forward that new signals must use namespaces in 
their params and we need to flag old signals that fail this for fixing in 

(and i bear some responsibility here as i "fixed" it to use the namespace so 
this signal could more easily be used elsewhere)

Aaron J. Seigo
humru othro a kohnu se
GPG Fingerprint: 8B8B 2209 0C6F 7C47 B1EA  EE75 D6B7 2EB1 A7F1 DB43

KDE core developer sponsored by Qt Development Frameworks
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
Url : 

More information about the Plasma-devel mailing list