signal messageButtonPressed(const Plasma::MessageButton button);

Marco Martin notmart at
Sat Feb 12 12:42:12 CET 2011

On Friday 11 February 2011, Aaron J. Seigo wrote:
> On Tuesday, February 8, 2011, Marco Martin wrote:
> > Hi all,
> > I see in Plasma::Applet that
> > void messageButtonPressed(const MessageButton button);
> > was changed in
> > void messageButtonPressed(const Plasma::MessageButton button);
> that sucks; specifying Plasma:: in the signature is absolutely required for
> it to be expected to work consistently. the only way for non-namespaced
> params to work in signals like this is if plasmoid writers include a
> "using Plasma" statement in their code which does a lot to invalidate the
> point of having a namespace in the first place.
> i suppose we can move back in this case, but it's really, really, really
> something we need to make consistent in libplasma2 as it is a source of
> ongoing annoyances.
to me honestly if it's ok for the only real user that i know of that we have  
right now of this particular feature, we can really leave it changed with the 
proper namespace ;)

Marco Martin

More information about the Plasma-devel mailing list