knotificationitem: api prettiness

Michael Jansen kde at
Wed May 27 00:15:53 CEST 2009

On Tuesday 26 May 2009 23:17:57 Marco Martin wrote:
> Hi all,
> was talking with richmoore about the api of libknotificationitem, wat did
> emerged is a thing i wasn't happy about but couldn't quite quantify before:
> 1) we have two way to set icons: by name and by pixmap, right now by name
> is setIcon()
> by pixmap is setImage()
> (that should reflect in dbus too)
> that looks a bit weird, would be better maybe setIconName() and setIcon()?

I would call it setIconByName. In the other case i could come to the 
conclusion i have to set a icon (setIcon()) and give it a name (setIconName())


> Plasma-devel mailing list
> Plasma-devel at

More information about the Plasma-devel mailing list